読者です 読者をやめる 読者になる 読者になる

私がRubyをインストールしたとき確認すること

rbenvやrvmでRubyをインストールしたときはirbを起動して次のチェックを行います。

↑キーを押してみる

readlineが正しく組み込まれていないとキーヒストリーが効きません。

require 'openssl'

opensslが正しく組み込まれていないとhttpsで通信する時にハマります。

require 'zlib'

zlibが正しく組み込まれていないと、いたるところでハマります。それはもう困ります。

require 'psych'

psychがrequireできないときはYAMLを扱うことができません。きっとRailsで困るでしょう。


うまく動作していないときはOSに必要なライブラリをインストールしてRubyの再コンパイルを行います。
他にも私はこんなチェックをしてるって人がいれば教えて下さい。